Page 1 of 3
Error connecting to default database

Posted:
Sun Mar 06, 2011 3:51 pm
by dyfp
PokerTracker3 will no longer allow me to log into any of my databases. I get an error connecting to default database message. Nor will it allow me to create a new database. This has happened after running an import.
Re: Error connecting to default database

Posted:
Sun Mar 06, 2011 5:23 pm
by WhiteRider
That normally indicates a problem with PostgreSQL, often caused by an over-zealous firewall.
Please try a reboot first, if you didn't already - that can often get PostgreSQL to start again.
Please check our
Firewall Guide.
Click Start (if you're running Windows XP click Run), type services.msc and hit enter. Locate the PostgreSQL service - is it running? If not, can you start it?
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 8:40 am
by dyfp
Hi,
Pretty sure it's not a firewall problem, been running the same firewall (Nortons) for years and no settings have changed, to be sure went in and set all the pokertracker and postgresql settings to ALLOW.
Still no joy.
When I look in Services Postgresql is not running, if I try and run it I get the following message
The PostgreSQL Database Server 8.3 service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs
any ideas ?
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 9:57 am
by kraada
Go into Control Panel -> Administrative Tools -> Event Viewer and look at the events in the Applications -> Windows folder. There should be errors relating to PostgreSQL listed there - could you copy and paste the error text here? That will shed some light on why things are stopping.
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 10:25 am
by dyfp
- System
- Provider
[ Name] PostgreSQL
- EventID 0
[ Qualifiers] 0
Level 2
Task 0
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2011-03-08T11:59:24.000Z
EventRecordID 278872
Channel Application
Computer Dyfed-PC
Security
- EventData
2011-03-08 11:59:24 GMT FATAL: could not create any TCP/IP sockets
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 10:41 am
by kraada
What operating system are you using?
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 10:43 am
by dyfp
Vista
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 11:01 am
by kraada
Click Start type cmd, right click it and click Run as Administrator.
At the command prompt type:
netsh winsock reset
then hit enter, then type:
netsh int ip reset
and hit enter. Reboot your machine and try starting the PostgreSQL service again.
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 11:44 am
by dyfp
Hi , no joy
System
- Provider
[ Name] Application Error
- EventID 1000
[ Qualifiers] 0
Level 2
Task 100
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2011-03-08T15:35:40.000Z
EventRecordID 278981
Channel Application
Computer Dyfed-PC
Security
Get this error
- EventData
postgres.exe
8.3.0.831
47a2edcd
MSVCR80.dll
8.0.50727.4053
4a594c79
c000000d
0001e898
bf0
01cbdda664587260
Then the same error as before
Re: Error connecting to default database

Posted:
Tue Mar 08, 2011 12:36 pm
by kraada
Then could you paste the contents of the C:\Windows\System32\drivers\etc\hosts here? You can open it up in Notepad.